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Preface
Copyright © 2021 PAX Technology, Inc. All rights reserved.

The Programs (which include both the software and documentation) contain proprietary information; 
they are provided under a license agreement containing restrictions on use and disclosure and are also 
protected by copyright, patent, and other intellectual and industrial property laws. Reverse engineering, 
disassembly, or decompile of the Programs, except to the extent required to obtain interoperability with 
other independently created software or as specified by law, is prohibited.

This document is provided for informational purposes only. All features and specifications are subject to 
change without notice. If there are any problems in the documentation, please report them to PAX in 
writing. This document is not warranted to be error-free. Except as may be expressly permitted in the 
license agreement for these Programs, no part of these Programs may be reproduced or transmitted in 
any form or by any means, electronic or mechanical, for any purpose.

Security Notice: No part of this publication may be copied, distributed, stored in a retrieval system, 
translated into any human or computer language, transmitted, in any form or by any means, without the 
prior written consent of PAX Technology, Inc.

PAX is a registered trademark of PAX Technology Limited in China and/or other countries. All other 
trademarks or brand names are the properties of their respective holders. PAX, PAXSTORE, POSDK, The 
PAX Portfolio Manager and/or other PAX products referenced herein are either trademarks or registered 
trademarks of PAX Technology, Inc. or its Affiliates. Other product and company names mentioned herein 
may be trademarks of their respective owners. 

The Bluetooth® word mark and logos are registered trademarks owned by Bluetooth SIG, Inc., and any use 
of such marks by PAX Technology, Inc. is under license. Other trademarks and trade names are those of 
their respective owners.

EMV® is a registered trademark in the U.S. and other countries and an unregistered trademark elsewhere. 
The EMV trademark is owned by EMVCo, LLC.

Android is a trademark of Google LLC.

TECHNICAL SUPPORT

If there is a problem while installing, registering, or operating this product, please make sure to review 
the documentation. If unable to resolve the issue, please contact PAX. The level of access to this Service is 
by the support plan arrangements made between PAX and the Organization. Please consult this support 
plan for further information about entitlements, including the hours when telephone support is available.

Monday-Friday 9:00 AM to 1:00 AM EDT
Saturday 9:00 AM to 5:00 PM EDT
Sunday Closed
Hours Subject to Change

TECHNICAL SUPPORT CONTACT INFORMATION

Phone: (877) 859-0099
Email: support@pax.us
URL: www.pax.us

mailto:paxstore.support@pax.us
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1. Introduction
1.1 Purpose 

Advanced Device Management

Ultra modern terminal management system

Industry-leading device management features designed to manage, control, and monitor all types of 
Android and Linux devices more efficiently.

• Automatic terminal deployment and software loading 

• Real-time application push and parameter management

• Remote terminal control, help-desk, and messaging

• Real time status of terminal hardware and applications 

• Live Geo-location of each Android payment device

This document provides the PAXSTORE North American Group release version 8.4 information.

1.2 Document Conventions

Acronym Definition

PAXSTORE North 
American Group

PAXSTORE is an innovative platform that provides modern administrative 
functionalities, real-time data, statistical reporting and hundreds of value-
added applications, to help unlock the full potential of Android Smart 
terminals, and turn these into a powerful business tool to boost in-store sales, 
improve shopping experience and increase customer loyalty.

Within this document, will be referred to as PAXSTORE.

Application Market 
Place

The PAXSTORE marketplace where applications are located and available for 
download. Note: The PAX Technology® payment applications are not directly 
visible in the Application Marketplace or from the terminal PAXSTORE client 
application.

Reseller The reseller level supports a company that resells credit card terminals and 
peripherals and offers credit card processing services with sub-resellers and 
merchants.

Reseller 
Administrator

This is a User-level within the PAXSTORE that manages the leading reseller and 
sub-resellers. Includes editing the main reseller account, adding, editing, and 
deleting sub-reseller accounts. The reseller admin also manages developers, 
applications, Users and User permissions, store layout, reports, terminals, and 
merchants.
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1.3 Intended Audience and Reading Suggestions
This PAXSTORE document is intended to provide User instructions and store descriptive information. 
There are various levels of Users and features available within the store. Each User level includes User 
instructions and feature information. The following should read this document:

• Resellers

• PAXSTORE Support

• PAX Support

2. Overall Description
2.1 Product Perspective
The PAXSTORE is an online marketplace for terminal applications and provides terminal management 
solutions. The PAXSTORE connects merchants and their PAX terminals with the opportunity to purchase 
and download applications. It also provides application developers a way to upload applications to be 
available online. 

2.2 Communication Method
The terminals will communicate with the PAXSTORE through the Internet. 

2.3 Product Features
The PAXSTORE supports an online marketplace for terminal applications, terminal, reseller, sub-reseller, 
merchant, application development, dashboard, application-level parameter, and download 
management.

3. The PAXSTORE Overview 
The PAXSTORE is an online marketplace for PAX terminal applications and provides terminal management 
solutions. The PAXSTORE connects resellers, merchants, and their PAX terminals to have applications 
available online. It also allows resellers to manage sub-resellers, merchants, terminals, terminal 
applications, terminal parameters, and downloads. It also includes the ability for Applications to be 
purchased and downloaded. It also allows application developers to upload applications in the PAXSTORE 
exclusively for their store or available to everyone.

4. Logging Into the PAXSTORE
This section covers the PAXSTORE login, including security processes implemented. 

Developer A developer or team of developers that create applications supporting PAX 
terminals and devices used on the PAXSTORE. The Developer registers to 
obtain login privilege as a Developer. The Developer, when ready, will submit 
their applications for signing. Once signed, the application can be added to 
their Reseller store.

Acronym Definition



v4.0 | 3

PAXSTORE N.A. Reseller User Guideer Guide

4.1 Login Fields and Security

4.1.1 LOGIN EMAIL ADDRESS

A valid email address is required to set up an account. The email address is used to send emails for 
resetting the password.    

4.1.2 LOGIN USERNAME

A Username is required to set up the User account. When prompted, enter a Username.

4.1.3 LOGIN USER GENERATED PASSWORD

An email will be sent to the email address entered in the User setup with a link to enter a new password 
or reset a password. When prompted, enter a password. The password length must be at least eight or 
more alphanumeric characters and must contain at least one uppercase character and at least one symbol 
(~`!@#$%^&*()-_+={}[]|\/:;”'<>,.?). The new password should not be the same as the previous four 
passwords. 
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4.1.4 LOGIN USER GENERATED PASSWORD EXPIRATION

It forces Users to periodically reset their passwords. This adds extra security by minimizing the impact of 
shared or compromised passwords. The password is set to expire in 30 days. The actual expiration date is 
unique for each user relative to the last date they reset their password.

4.1.5 RE-ACTIVATED USER

• User Management function. Reactivated Users will not be suspended again 
within 48 hours.

• Session timeout is set to 30 minutes for improved security.

4.1.6 TWO-FACTOR AUTHENTICATION

The login process includes an optional two-factor authentication login for additional security. First 
entering a User password and secondly the optional Google Authenticator password code. 

Google verification uses their Google Authenticator cell phone application to display the authenticator 
code. Using your cell phone provides an additional layer of security since the person attempting 
unauthorized access would not have your phone. Codes are uniquely crafted for your account when you 
need them. If you choose to use verification codes, they will be sent to your phone via Google mobile app. 
Each code can only be used once. 

4.1.7 CAPTCHA

An additional security step involves entering a separate unique CAPTCHA verification code. 

This form of CAPTCHA requires that the User type the characters of a distorted image, sometimes with an 
obscured sequence of letters or digits that appears on the screen. 

Using CAPTCHA makes it difficult for a bot to reset a User's password and gain access to your system. A 
CAPTCHA is a scrambled image that a human can read but a bot cannot. The User must enter the 
characters shown on the screen to verify that they are human. 

4.1.8 IDLE TIMEOUT PERIOD

When a User does not perform any actions for a certain period, the User is automatically logged out of the 
system and forced to log back in. For example, suppose the User is accessing the PAXSTORE from a 
computer and fails to log out, in that case, this will help ensure that the User's account gets logged out, 
eventually preventing any unauthorized access to the system. By default, Users are logged out after 30 
minutes of inactivity.

4.1.9 INVALID LOGIN CREDENTIAL

If the login password fails, a message will be displayed “Invalid login credential, your account will be 
locked after five attempts.” If the password attempts exceed the displayed value the User will be locked 
out with the following message “User account is locked, please try again after 30 minutes”. After 30 
minutes, the User can retry logging in. 



v4.0 | 5

PAXSTORE N.A. Reseller User Guideer Guide

4.2 How to Log In
This section will cover the log-in process. It will not include User setup. 

Includes the following: 

• Successful login

• Successful login with two-factor authentication

• Forgot password

• Maximum login attempts

4.2.1 LOGIN WITH OPTIONAL TWO-FACTOR AUTHENTICATION DISABLED

4 .2.1.1 Step 1. Home Page Login

From the PAXSTORE home page, select the [LOGIN] icon on the upper right-hand corner of the page.
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4 .2.1.2 Step 2. Enter Login Email Address and Password

Enter the [User email address] > [password] > [LOGIN].

Note: User email accepts alpha, numeric and special characters.
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4 .2.1.3 Step 3. Successful Login—User E-mail Displayed

Upon successful login, the User’s email address will be displayed in the upper right-hand corner of the 
page.
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4.2.2 LOGIN WITH OPTIONAL TWO-FACTOR AUTHENTICATION ENABLED

4 .2.2.1 Step 1 Home Page Login

From the PAXSTORE home page, select the [LOGIN] icon on the upper right-hand corner of the page.
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4.2.3 STEP 2. ENTER LOGIN EMAIL ADDRESS AND PASSWORD

Enter the User email address and password and then select [LOGIN].
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4 .2.3.1 Step 3. Google Authenticator Code

If the optional two-factor authentication is enabled, the Google Authenticator code will be required to log 
in. Refer to the Google Authenticator application on your phone for the authenticator code. 

Cell Phone Google Authenticator Code 
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Then, enter the 6-digit Google Authenticator code and select [OK].

4 .2.3.2 Step 4. Successful Login—User E-mail Displayed

Upon successful login, the User’s email address will display in the upper right-hand corner of the page. 
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4.2.4 LOGIN WITH OPTIONAL TWO-FACTOR AUTHENTICATION AND CAPTCHA

4 .2.4.1 Step 1. Home Page Login

From the PAXSTORE home page, select the [LOGIN] icon on the upper right-hand corner of the page.
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4 .2.4.2 Step 2. Enter Login Email Address and Password

Enter the User email address and password and then select [LOGIN].
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4 .2.4.3 Step 3. Re-Enter Login with Verification Code

If the email address or the password was not correct a new login screen appears with the message 
“Invalid login credential”, then enter [email address] > [password] > [verification code] > [LOGIN].
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4 .2.4.4 Step 4. Google Authenticator Code

If the optional two-factor authentication is enabled, the Google Authenticator code will be required to log 
in. Refer to the Google Authenticator application on your phone for the authenticator code. 

Cell Phone Google Authenticator Code 
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Then, enter the 6-digit Google Authenticator code and select [OK].

4 .2.4.5 Step 5. Successful Login—User E-mail Address Displayed

Upon successful login, the User email address will display in the page’s upper right-hand corner and the 
User will land on the Application Marketplace page. 
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4.2.5 FORGOT PASSWORD AND RESETTING PASSWORD

This section covers resetting the password.

4 .2.5.1 Step 1. Home Page Login

From the PAXSTORE home page, select the [LOGIN] icon on the upper right-hand corner of the page.
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4 .2.5.2 Step 2. Enter Login Email Address and Password

Enter the User email address and password and then select [LOGIN].
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4 .2.5.3 Step 3. Request New Password

If the email address or the password was not correct, a new login screen appears with “Invalid login 
credential.” To reset the password, select the [Forgot your password] option. 
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4 .2.5.4 Step 4. Reset Password

To reset the password, enter the [login email address] > [verification code]. To send the password reset 
email, select [SEND RESET PASSWORD E-MAIL]. To bypass the reset email and to re-enter the login 
information, select the “Login” option. 

4 .2.5.5 Step 5. Verify Reset Password E-mail Request

An email will be sent to the email address provided on the reset password screen.
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4 .2.5.6 Step 6. Reset Password E-mail

Check your email for the Reset Your Password email message. Select the [RESET PASSWORD] option in 
the email message. The link will expire in 48 hours. The link will take you to the password reset page.
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4 .2.5.7 Step 7. Reset Password—Disable Two-Factor Authentication

When prompted, enter a new password. The password length must be at least eight or more 
alphanumeric characters and must contain at least one uppercase character and at least one symbol 
(~`!@#$%^&*()-_+={}[]|\/:;”'<>,.?). The new password should not be the same as the previous four 
passwords. 

To disable two-factor authentication, select the box next to the Disable two-factor authentication. 

To confirm and reset, select [OK].
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4 .2.5.8 Step 8. Password Reset Successfully

The password has been successfully reset. To log in, select [LOGIN TO MY ACCOUNT].
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4 .2.5.9 Step 9. Enter Login Email Address and Password

Enter the User [email address] and [password] and then select [LOGIN].
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4 .2.5.10 Step 10. Google Authenticator Code

If the optional two-factor authentication is enabled, the Google Authenticator code will be required to log 
in. Refer to the Google Authenticator application on your phone for the authenticator code.

Cell Phone Google Authenticator Code
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Then, enter the 6-digit Google Authenticator code and select [Submit].
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4 .2.5.11 Step 11. Successful Login—User E-mail Address Displayed

Upon successful login, the User E-mail Address will display in the upper right-hand corner of the page.
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4.2.6 MAXIMUM LOGIN ATTEMPTS WITH TIME OUT

If the login password fails, a message will be displayed “Invalid login credential, your account will be 
locked after five attempts.” If the password attempts exceed the displayed value, the User will be locked 
out with the following message “User account is locked, please try again after 30 minutes”. After 30 
minutes, the User can retry logging in. 

4 .2.6.1 Step 1. Home Page Login

From the PAXSTORE home page, select the [LOGIN] icon on the upper right-hand corner of the page.
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4 .2.6.2 Step 2. Enter Login Email Address and Password

Enter the User email address and password and then select [LOGIN].
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4 .2.6.3 Step 3. Re-Enter Login with Verification Code

If the email address or the password was not correct, a new login screen appears with the message 
“Invalid login credential,” and the CAPTCHA verification code entry is required. Follow prompts and enter 
the [email address] > [password] > [verification code] > [LOGIN].
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4 .2.6.4 Step 4. Re-Enter Login with Verification Code—2nd Attempt

If the email address, the password. or the CAPTCHA codes were not correct, a new login screen appears 
with the message “Invalid login credential,” and the CAPTCHA verification code entry is required. Follow 
prompts and enter the [email address] > [password] > [verification code] > [LOGIN].
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4 .2.6.5 Step 5. Re-Enter Login with Verification Code—3+ Attempt

If the email address, the password, or the CAPTCHA codes were not correct, a new login screen appears 
with the message “Invalid login credential, your account will be locked after 3 attempt(s)”. The CAPTCHA 
verification code entry is required. This message mentions there are only three more failed password 
attempts before a lockout occurs. Follow prompts and enter the [email address] > [password] > 
[verification code] > [LOGIN].
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4 .2.6.6 Step 6. Account Lock Out

If the password was incorrect, a new login screen might appear with the message “User account is locked, 
please try again after 30 minutes”. After 30 minutes, the User can retry logging in.
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5. App Store
The App Store is where applications are located and available for purchase and download. Some examples 
might be ID verification, time and attendance, or a POS application. The home page also features a 
marketing space with various size banners.
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Some applications that are not directly visible in the Application Marketplace. Some examples might 
include a payment application, firmware update, or other applications that the reseller may have 
configured to be pushed out to selected terminals. 

The Marketplace also includes various reports and displays Featured and Hot application sections, which 
can be sorted by downloads and order by date filters. Other sorting options include; display applications 
by categories such as retail, restaurant, logistics, and chain stores. 

PAXSTORE Application Global Marketplace Home Page 

There are navigation links on the Market Place home page, various application search options and listings 
of applications. Below describes the Application Market Place home page.

5.1 Reseller Market Place Home Page Details
App Store: There is an APP Store button at the top right-hand center area of the page. Selecting this link 
takes the User to the GLOBAL APPLICATION MARKETPLACE.

Developer Center: At the top right-hand area. there is a Developer Center link. Selecting this link takes the 
User to the App Distribution and Promotion home page. 
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Multi-Links: The Multi-Link box my be displayed depending on whether the user is logged in or not and 
access privileges. When selected, opens a pop-up window that displays links to various pages.

Multi-Link Popup Window: When the Multi-Link icon is selected, the following pop-up window will 
appear. Various links can be displayed depending upon the User’s access privileges. In this example, within 
the Global Marketplace is the APP Store, Developer Center, and the Administrator Center, and within the 
Resellers Marketplace, the APP Store and the Administrator Center. Selecting an icon will take the User to 
the described home page supported by the login privileges. 
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Language Section: At the top right-hand corner area, a feature that supports the option to select 
supported languages. Selecting the icon displays a list of supported languages. Selecting a language 
changes the site to display text in the supported language as English and Chinese.

Login: At the top right-hand corner area is the login icon. Selecting this icon takes the User to the 
Application Market login/sign up home page.

Log In ID: If the User is logged into the website, the User’s ID will display in the upper right-hand corner of 
the page in place of the Sign In icon. 

Search Feature: Near the top center of the page is a search feature that supports search by application 
name or keyword. 
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Top Banner: Two locations on the Marketplace home page can display advertising or informational 
banners. Both banners are configured only within the Administrator Center Global Dashboard section of 
the site. These are not accessible to the reseller level administrator.

Featured: The Featured section displays featured applications that the Reseller Administrator configures. 
The Reseller Administrator can add or remove applications to be featured within the Dashboard section. 
This section also includes a drop-down sort option by selecting the View All icon to display featured 
applications and then select the FILTER to sort by All, Free, and Charged downloads.   Another sort option 
is available by selecting SORT, then Sort by Downloads, or Sort by Updated Time. 

The applications display as thumbnails, and when the thumbnail is clicked, an additional application 
detailed page is opened. When the thumbnails are hovered over, the application price and the number of 
downloads are displayed. 

5.2 Application Detail Page
Breadcrumb: The top of the page features a breadcrumb for easy navigation. Select any one of the 
breadcrumbs for a shortcut to the selected page. 

Search Icon: A search icon supports a search by application name or keyword located in the top mid-right 
side.
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5.2.1 MAIN SECTION OF THE APPLICATION DETAIL PAGE. 

The main section of the application detailed page includes the following headers: 

• Application Icon

• Application Name

• Version List and Count

• Brief Description

• Scan Result

• Category

• Model

• Supported OS

• Downloads

• Screen Shots

• Description

• Release Notes

Application Detail Home Screen

5.2.2 MAIN SECTION DEFINITIONS 

• Application Icon: Displays the application icon and pulls the icon file directly 
from the application file. Supports. PNG, JPG, and JPEG. The size is fixed when 
loaded on the web page, and the image size is changed to support the image 
requirements. 

• Application Name: Displays the name of the application name. 
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• Brief Description: A very brief description of the application. 

• Version List and Version Count: Displays a list of previous versions and a total 
count of versions. 

• Category: Application category type such as retail, restaurant, petroleum, 
attendance, and reports. Model: The compatible terminal name. 

• Supported OS: Supported operating system. 

• Developer: Name of the developer for the application. 

• Screenshots: Screenshot images of the application. 

• Description: Detailed description of the application. 

• Release Notes: Release date and a summary of the release notes. 

A subsection of the application detail page supports the ability to push and purchase the application. This 
section includes the following headers:

• Application Icon

• Application Name

• Number of downloads

• Price

• Size

• Version

• Package Name

• OS Authorization

• Update Date

• Push Button 

5.2.3 SUBSECTION DEFINITIONS

• Purchase: Clicking on the Push button takes the User to another page to begin 
the purchasing process. 

• Application Icon: Displays the application icon and pulls the icon image file 
directly from the application file. This feature supports PNG, JPG, and JPEG file 
types. When loaded on the web page, the image file size is changed to keep the 
image requirements for the page. 

• Application Name: Displays the name of the application name. 

• Number of Downloads: Displays the number of successful downloads. 

• Price: Displays the price for the application 

• Size: Displays the application file size. 

• Version: Displays the application version information. 

• Package Name: Displays the application file name. 
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• OS Authorization: Displays the operating system authorization such as the 
permissions WRITE_EXTERNAL_STORAGE and the READ_EXTERNAL_STORAGE. 

• Update Date: Displays the application build date. 

• Push Date: Displays the application push date. 

6. Developer
For developer-level information, please refer to the PAXSTORE Developer Guide.

6.1 CloudMessenger
A Marketplace Admin feature. When the value-added service “CloudMessage” is enabled in the 
marketplace, developers can use the service directly in the Developer Center.
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7. Role Management
The Role Management feature supports access control for Users: no access, read-only access and full 
privileges for each option. 
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7.1 Role Management Options
Below are role management examples with options supported for an Administrator and Operator. It is 
possible to add a User to the User List and Create a NEW ROLL.

7.1.1 STEP 1. ADD A NEW USER

The following instructions will help guide you through adding a new User and assigning roles to the new 
User. 
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7.1.2 STEP 2. LOGIN

From the PAXSTORE home page, select the [LOGIN] icon in the upper right-hand corner of the page and 
log in. If the login is successful, the GLOBAL MARKETPLACE page will open.
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7.1.3 STEP 3. MULTI-LINK

From the GLOBAL MARKETPLACE page, select the Multi-Link icon and then select the Reseller 
Administrator icon. 
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7.1.4 STEP 4. SELECT ROLE MANAGEMENT

Select from the category section [Role Management] > [Role Management].

7.1.5 STEP 5. ROLE MANAGEMENT PAGE

After selecting the Role Management feature in the category section, the Role Management screen will 
display. By default, the various Role Management types will display with the User LIST highlighted, and 
any existing Users will display in the corresponding Role Management sections. Please note that a User 
cannot edit or delete your profile. 
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7.1.6 STEP 6. ADD USER

It is possible to select the Role Management Administrator or the Operator for the User. For this exercise, 
please choose the Operator Role Management option. Select the [+ User] icon at the bottom of the 
Operator level section to add a new User. 

7.1.7 STEP 7. CREATING THE NEW USER

When the + User icon is selected, the Add User to Role pop-up window will appear. Enter the Users email 
and select [OK] to save or CANCEL to exit without saving. 
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7.1.8 STEP 8. DELETE A USER

When it is required to delete a User, hover the cursor near the right side of the User name, and a 
“Trashcan Icon” will appear. To delete the User, select the [Trash can icon] > [OK] to confirm the delete or 
CANCEL to ext without saving. 

7.1.9 STEP 9. ROLE SETTINGS

When the User is added to the Operator Role, the User automatically is configured to the existing 
Operator Level settings. These settings are not adjustable. All Users added to the Operator Role will 
assume the Operator Role settings. For Custom Role settings, create a brand-new Role Management 
Profile. Each User added to the Custom Role will assume the settings in the Custom Role. To set custom 
Role Management settings for a single User, create a custom Role just for the User. 

7.1.10 STEP 10. SELECT ROLE DETAIL

To view and edit Role privileges select [Role Management] > [Role Management] > [Role Detail]. The 
Operator Level does not allow edit of the privileges and is hard coded. 
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7.1.11 STEP 11. ADD A NEW ROLE

To add a new Role, select [Role Management] > [Role Management] > [Role Detail] > [+ ROLE].
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7.1.12 STEP 12. NEW ROLE WINDOW

When the + ROLE is selected, a Create Role pop-up window will appear. In the Name field, enter a case- 
sensitive name for the new Role. Then check the box next to the privilege to be supported by the new 
Role when the role is selected and will display extended privileges in the box at the bottom. Use the scroll 
tool on the right side to scroll all down to the bottom to display all available roles. The box at the bottom 
includes additional privilege settings for the ones enabled on the list above. The privileges and extended 
privileges are displayed in the box at the bottom and can be disabled by hovering over the privilege and 
selecting the [X]. To save changed, select [OK] to save and exit or select CANCEL to exit without saving. 
Some Administration privileges are not available for non-administration Role levels. 

The following privileges will be listed: 

• Monitoring (Dashboard, Terminal Geolocation)

• Task (App List)

• Management (Terminal Management, Group Management, Parameter 
Templates)
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Lower Role Box Privileges 

The following privileges and supporting privileges will be displayed within the bottom section if the 
privilege is selected above. To disable any privileges in the box, hover the cursor over the desired privilege 
to disable and select the [X] next to the description. Once all the privileges have been set up, select [OK] 
to save or CANCEL to exit without saving. 

• Dashboard

• Terminal Geolocation

• App List

• App List-Read Only Privileges

• Terminal Management

• Terminal Management—Read Only Privileges

• Terminal Management—Full Privileges

• Group Management

• Group Management—Read Only Privileges

• Group Management—Full Privileges

• Parameter Templates—Read Only Privileges

• Parameter Templates—Full Privileges

Lower Section of the Scrolling Privileges
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7.1.13 STEP 13. NEW ROLE DISPLAYED

After the new Role has been created and the [OK] button selected, the new Role will display. Please use 
the instructions above to add a new User and configure privileges to the new Role. 

7.1.14 STEP 14. VIEW ROLE USERS

To view existing Role Users, select the [Role Management] > [Role Management] > [Roll Users]. When 
selected, a new pop-up window will appear displaying existing Users. Enter a name on the Search line to 
search for users and then select the magnifying glass icon to search. To exit, select CLOSE to exit. 
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7.1.15 REPORT CENTER

Added a new 'Report Center' privilege. Marketplace administrators can now create a separate role for the 
'Report Center.'
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7.2 Operational Control
The enhanced Operational Control User interface makes it clearer and easier to navigate and locate 
options.

To access Operational Control select [Role Management] > [Operational Control]. 

7.2.1 OPERATION CONTROL FEATURES

To access: Select [Role Management] > [Operation Control] > [enable/disable desired option] >               
[+ OPERTATION DISTRIBUTION] > [User Email] > [OK]. 

The Operation Control supports the following options.

General Setting

• PUK Upload - In [General Setting]-[PUK & Signature], whether allow User to 
upload PUK.

• RKI Setting - In the reseller detail page or general setting page, whether allow a 
User to set RKI.

Terminal Configuration

• APP Uninstall - In [Group Management] or terminal detail page, whether allow 
User to uninstall app.

• Import/Export Terminal - In terminal detail page, whether allow User to change 
PED related configuration.

• Push App - In [Group Management] or terminal detail page, whether allow User 
to push app.

• Push Firmware - In [Group Management] or the terminal detail page, whether to 
allow the User to push an application.
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• RKI Firmware - In [Group Management] or terminal detail page, whether allow 
User to push firmware.

• RKI Push - In [Group Management] or terminal detail page, whether allow User 
to push RKI tasks.

• Remote Lock Terminal - In terminal detail page, whether allow User to lock 
terminal remotely.

• Restart Terminal - In terminal detail page, whether allow User to restart terminal.

• Send Message - In [Group Management] or terminal detail page, whether to 
allow the User to send message.

• Terminal Logcat - In terminal detail page, whether allow User to download 
terminal logcat.

Terminal Control

• APN Control - In the profile page, whether allow User to set APN.

• CardReader Control - App White list - In the profile page, whether allow User to 
set CardReader control - App White list.

• Change Terminal Setting Password - In the profile page, whether to allow the 
User to change terminal setting password.

• Geo-Fence - In the profile or terminal detail page, whether to allow the User to 
set the geo-fence.

• IP Whitelist - In the profile page, whether allow the terminal to open the IP 
whitelist validation.

• Profile Setting - In the reseller/merchant detail page, whether allow the User to 
configure the profile for the current organization.

• Wi-Fi Control - In the profile page, whether to allow the User to set Wi-Fi.

Value-Added Service

• AirViewer - In terminal detail page, whether allow the User to use AirViewer.

• AirViewer - Unattended Mode - In terminal detail page, whether allow User to 
use AirViewer for unattended device (supported models: IM30, SK600, SK800).
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7.2.2 AIRVIEWER PERMISSION

Optimized AirViewer permission control under 'Operation Control.' Users with read-only Terminal 
Management privileges can now access AirViewer instead of previously when full privileges were 
required.
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8. September 2018 Update Summary
To continuously improve the functionality of the PAXSTORE, an upgrade occurred on the evening of 
September 9th, 2018. We kept intact the database; therefore, your accounts, application settings, and 
terminal downloads are still there. 

New Changes: 

• Terminal Management Support for traditional PAX non-Android terminals

• PAXSTORE Marketplace has been renamed to the BroadPOS Marketplace

• UAT Marketplace has been renamed to the Test Marketplace

• Added Terminal Monitoring Features in the Terminal List and in the Terminal 
Detail

• Two Factor Authentication (optional)

• A Single Email User can be on Multiple Reseller Accounts

• Other minor enhancements/fixes

8.1  Support for Traditional PAX non-Android Terminals
Going forward, terminal management will be supported for selected PAX traditional non-Android 
terminals on the PAXSTORE. Please contact your PAX Sales Engineer or paxstore.support@pax.us for a list 
of supported terminals. Eventually, all PAX traditional non-Android terminals will be supported.

8.2 PAXSTORE Marketplace has been renamed the BroadPOS Marketplace
The PAXSTORE Marketplace has been renamed the BroadPOS Marketplace. 

8.3 UAT Marketplace has been renamed the Test Marketplace
The UAT Marketplace has been renamed the Test Marketplace. 

8.4 New Features within Terminal Monitoring, Terminal List, and in the 
Terminal Detail
There are new features and changes in the Terminal List and Terminal Detail sections. 

• New Font

• New Icons

• New Search Filter options

• New Check Boxes
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8.5 Terminal Management 
A Terminal Management Category has been implemented to improve the layout of main and sub-main 
folders. 

To access select [Terminal Management] > [Terminal Management].

8.6 New Terminal Management Category Icons
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9. Dashboard
The Dashboard, accessed from the category tree section, displays various features consisting of hardware 
and software status data. The dashboard can be modified using the Edit option. Most of these features 
use Widgets to display the information. HowThe Widgets can be added or removed as needed. The layout 
can also be changed by selecting from pre-configured arrangements.

To access: [Dashboard] > [Dashboard].

 

9.1 Terminal Digital Card
The Terminal Digital Card feature, when enabled, is displayed in the Dashboard area with displayed 
summary information and detailed download reports. The feature is not displayed by default. Add the 
option using the + ADD Widget feature.

The following reports are supported:

• Activated Terminals - Displays a summary of the number of activated terminals 
and an exported detail report of all activated terminals.

• Out of Geo-Fence - Displays a summary of the number of terminals outside the 
Geo-Fence and an exported detail report of all terminals outside the Geo-Fence.

• Terminal Offline Time > 15 Days - Displays a summary of the number of terminals 
offline 15 or more days and an exported detail report of all terminals offline 15 or 
more days.

• Activated Merchants - Displays a summary of the number of activated merchants 
and an exported detail report of the activated merchants.

• Activated Sub-Resellers - Displays a summary of the number of activated sub-
resellers and an exported detail report of all activated sub-resellers.

The report summary values will be displayed in each report sector. Hovering the cursor within the report 
sector will display a drop-down arrow. Selecting the drop-down arrow will download the detailed report. 
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To configure which reports are displayed, select the settings icon in the upper right-hand corner and 
select which reports will be displayed. Within the Settings option, it is possible to set the Terminal Offline 
Time to 7, 15, 30, and 90 days.



v4.0 | 61

PAXSTORE N.A. Reseller User Guideer Guide

The download reports include all of the terminals or merchants with terminal or merchant details in the 
report. Below is a sample of the Export Activated Terminals report.

The downloaded report will include an email notification with a link to the report.
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9.2 Terminal Geo-Location

9.2.1 GEOLOCATION MAPPING

A Geolocation mapping format implemented supports terminal location information. 

The Terminal Geo-Fence feature tracks the terminal location. The feature also can provide location status 
reports to show any terminals outside of the designated geo-location zone.

To access the Geo-Fence parameters select [Terminal Management] > [Reseller/Merchant] > [Profile] > 
see Terminal Control.

9.2.2 LOCATION DATA UPLOAD

The Location Data Upload parameter enables or disables the terminal location report.
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9.2.3 GEO-FENCE

When the Geo-Fence parameter is enabled, the system will alert when the terminal is outside of the geo-
fence. It only works for the terminals which geo-fence is defined.

9.2.4 AUTO-SET CENTER POINT

When the Auto-Set Center Point parameter is enabled, it automatically sets the current terminal position 
as the center point of the geo-fence. 

9.2.5 GEO-FENCE SAFETY RADIUS

This parameter sets the Geo-Fence radius for the terminals. The center point of the fence should be 
defined on the terminal detail page. 2000-9999999 meters.

10. Welcome
A welcome page is displayed after logging in. Shown on the left, is the existing navigation Category Tree 
List. A friendly Hello greeting to the user name email and a Welcome to the Marketplace name is 
displayed.

• Hello username@email.com

• Welcome to Marketplace Name



v4.0 | 64

PAXSTORE N.A. Reseller User Guideer Guide

11. Marketplace Home Page
That Marketplace Home page displays advertising banners, featured, hottest, and the latest applications. 
Search filters are available to search applications by App Type, Business Category, and Charge Type. 
Another search field is available to view applications by Ranking as Latest, Download, and Paid.

 To Access: Select the [Marketplace Name] or [Logo] in the upper left corner of the page.

11.1 Featured Applications
The Marketplace home page has been re-designed, which includes a new section called “Featured.” When 
configured can display up to nine featured applications. 



v4.0 | 65

PAXSTORE N.A. Reseller User Guideer Guide

The feature is configured in [General Settings] > [General Setting] > [Featured section] > [EDIT] > [+ 
FEATURED APP] > [CLOSE].
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11.2 More Advertising Space
The Marketplace home page has been redesigned to provide more advertising space.

Note: Existing advertisement banners may require adjustments, and re-upload the banners to support 
the enhanced design.

The advertising setup is accessed by [General Setting] > [UI Setting] > [Web Portal] > [Web Portal].
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12. PAXSTORE Client
The PAXSTORE Client is a PAX application that runs on the terminal that supports terminal management 
and editing options.

12.1 Enhanced Battery Management
Enhanced the battery management power level check feature before an Application self-updates.

12.2 Features
• Includes download progress display in the notification bar for pushing apps.

• Support for the Russian language.

• Support for terminal Replacement with TID.

• Support for upload firmware resource version.

• Support for detail log upload.

• Support for the Italian language.
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12.3 PAXSTORE Client Application
The PAXSTORE Client application for download is at the bottom of the Dashboard home page. The User 
must be logged in to access the link. Select [Store Client], and the application will download locally to a 
PC. Copy the Store Client application to the terminal via Bluetooth® and install it into the terminal.

12.4 Bluetooth® profile configuration
This new feature enables or disables Bluetooth® in devices. The next time the device connects to the 
PAXSTORE, the devices Bluetooth setting will be updated. 

To access select [Terminal Management] > [Reseller or Sub-Reseller or Merchant] > [Profile] > [Terminal 
System Configuration] > [Bluetooth] > [Enable] > [SAVE].
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12.5 Wi-Fi or Ethernet only for Push Task
When enabled, the new feature will only allow a Push Task to occur when the device is connected with a 
Wi-Fi or Ethernet connection and does not allow the Push Task over the wireless cellular data connection. 
When disabled, the Push Task can occur over a cellular data connection.

To access, select [Terminal Management] > [Reseller or Sub-Reseller or Merchant] > [Terminal List] > 
[desired Device] > [+ PUSH APP] > [desired Application] > [Push Configuration] > [Wi-Fi Only] > [Enable] 
> [ACTIVATE].
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12.6 PAXSTORE Client Home Page Advertisement
The entire Client page design is to align with the updated PAXSTORE advertising enhancements.

To configure advertising settings, in the PAXSTORE General Settings > UI > Store Client > to display up to 9 
Featured Apps displayed in the Marketplace Home Page.

The setup for advertising the PAXSTORE is pushed to the terminal and displayed on the PAXSTORE client 
home page. 

The Client Home page includes the same theme colors and logo format as the PAXSTORE.

12.7 PAXSTORE Client Pop-up Message
The PAXSTORE Client supports enhanced pop-up message sent from the PAXSTORE with a Title line.

12.8 PAXSTORE Client Feature Apps
The PAXSTORE Client includes the Featured App section on the home page. The PAXSTORE will send the 
same Featured App information to the terminal that is configured for the store.
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13. Group Management
The Group Management section includes the ability to send a task to terminals including parameter 
values, text messages, RKI, OS, or uninstall applications. 

13.1 Parameter Variable Ignore Line Item with “D”
A feature in Parameter Variables and the import file is if a “D” is added to the Status field of the desired 
line item, it will be ignored when Pushed to the terminal. This feature is often used when using the same 
import template for various Push Tasks to ignore selected parameter variables.

To access, select [Group Management] > [General or Dynamic Group] > [Group Name] > [Parameter 
Variables] > [Import File] > [Status] > enter [D] into the desired parameter variable line item.
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13.2 Group Task Button Name Change to COMPLETE
The Group Push Task button “Disable” changed to “COMPLETE” after a successful Push.

To access, select [Group Management] > [General Group or Dynamic Group] > [Group Name] > [Push 
Task Type] > [Push Task Name] > [Activate] > [Complete].



v4.0 | 73

PAXSTORE N.A. Reseller User Guideer Guide

13.3 Push App List Button Name Change
The Group Management Group Detail Push App List, Push Firmware List, Push Message List, Push 
Uninstall App List button names have changed to Push App, Push Firmware, Push RKI, Push Message, and 
Uninstall App.

To access, select [Group Management] > [General Group or Dynamic Group] > [Group Name] > [Push 
Task] > Push App, Push Firmware, Push RKI, Push Message and Uninstall App.
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13.4 Push Firmware 
Added the “Push Filter” feature for ‘Push Firmware.” Previously the push filter function was only available 
for “Push App,” Now, the Users can use the same push filter when pushing firmware, resource packages, 
and modem packages. 

 

P
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13.4.1 PUSH RKI 

The error message was optimized when it returned during RKI group push. In previous versions, only the 
first error message returned if there were errors with RKI group pushing. The RKI server will return all the 
error messages at once, useful for problem resolution. 
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13.4.2 SEARCH OPTIMIZATION

The Terminal Search feature has been optimized for the Resellers. The terminal search feature defaults to 
the terminal serial number, optional search tools include the terminal TID and terminal name. The 
terminal search optimization is implemented in all terminal search locations in Terminal Management and 
Group Management sections.

Select: [Group Management] > [General Group] > [Group Name] > [Terminal List] > [Terminal Search].

Selecting the terminal search drop down arrow displays the terminal SN, TID, and Name search options.
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13.4.3 GROUP PUSH FILTERS

A Marketplace Owner and Reseller feature the Group Push Filters allow the ability to filter a Push App or 
Firmware by selecting a specific filter option and then defining that filter. Each filter option has unique 
sub-filter options to further define that filter. The Group Push Filters support both General and Dynamic 
Group types. 

Filters Options

• App Version

• Firmware Version

• Modem Package Version

• Terminal Activation Time

• Merchant Type

• Mobile Carrier

Filter Type:

• App Version

• Method

• Equal to

• Not Equal to

• Before

• After

• App Version

• List of App Versions

• List of App Versions

Filter Type:

• Firmware Version

• Method

• Equal to

• Not Equal to

• Before

• After

• Firmware Version

• List of Firmware Versions

• List of Firmware Versions
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Filter Type:

• Modem Package Version

• Method

• Equal to

• Not Equal to

• Before

• After

• Modem Package Version

• List of Modem Package Versions

• List of Modem Package Versions

Filter Type:

• Terminal Activation Time

• Start Time

• Select Date and Time

• End Time

• Select Date and Time

Filter Type:

• Merchant Type

• Method

• Equal to

• Not Equal to

• Merchant Type

• List of Merchant Types

• List of Merchant Types

Filter Type:

• Mobile Carrier

• Method

• Equal to

• Not equal to

• Please Select

• T-Mobile
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To view select: [Group Management] > select from the General Group or Dynamic Group [Group Name] > 
[Push Task] > [Push App] > select desired Push App from the list of existing Push App List [Push App] > [+ 
FILTER] > [App Version Drop Down Arrow]. 

Note: Can also create a new Push Task to access this feature.

After selecting the drop down arrow, the various filter options will display. Select the desired filter and 
sub-filter options.
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13 .4.3.1 APP Version Filter

The App Version filter provides the ability to select an application and the version of the application to 
download to the device.

Select: Filter Type: [Download Arrow] > [App Version] > [Method Drop Down Arrow] > select desired 
Method option [Method] > [App Version Drop Down Arrow] > select desired application [Application] > 
desired application version [Application Version] > [OK] > [SAVE]. 

 Select: [App Version] > 
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> [Method Drop Down Arrow] >

Note: The red asterisk indicates a required field.

> select desired Method option [Method] > 

Note: In this example, ‘Equal to’ was selected.
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> [App Version Drop Down Arrow] >

Note: The red asterisk indicates a required field.

> select desired application [Application] > [Version Drop Down Arrow]. 

Note: In this example AirViewer was selected.
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> desired application version [Application Version] > [OK] >

Note: In this example version 2.7.0 was selected.

> [SAVE]. 
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> select the [Edit Icon] to edit the filter or the [Delete Icon] to delete the filter.

Push Filter setup is complete.
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13 .4.3.2 Firmware Version Filter

The firmware version filter provides the ability to filter versions of firmware to select from for download 
to the devices.

Select: [+Filer] > Filter Type: [Download Arrow] > [Firmware Version] > Method [Drop Down Arrow] > 
select desired Method [Method] > Firmware Version [Drop Down Arrow] > select desired [Firmware 
version] > [OK] > [SAVE]. 

Select: [+ Filter] > Filter Type: [Download Arrow] >  
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> [Firmware Version] > 

> Method > [Drop Down Arrow] > 

Note: This is a required field.
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> [Equal to] >

Note: In this example ‘Equal to’ is selected.

> Firmware Version [Drop Down Arrow] > 

Note: This is a required field.
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This step displays the various versions of the firmware based on the prior settings. There is a Search field 
that supports searching by keying in the firmware file name.

Note: In this example, A60_PayDroid_6.0_Leo_V07_1.10.20210128 was selected.

> select the desired [Firmware Version] > [OK].

> [SAVE]. 
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Completed Firmware Filter.

> select the [Edit Icon] to edit the filter or the [Delete Icon] to delete the filter.
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13 .4.3.3 Modem Package Version Filter

The Modem Package Version filter provides the ability to filter versions of modem packages to select from 
for download to the devices.

Select: [+Filer] > Filter Type: [Download Arrow] > [Modem Package Version] > Method [Drop Down 
Arrow] > select desired Method [Method] > Modem Package Version [Drop Down Arrow] > select 
desired [Modem Package Version] > [OK] > [SAVE]. 

Select: [+ Filter] > Filter Type: [Download Arrow] >
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> [Modem Package Version] >

> Method [Drop Down Arrow] > 

Note: This is a required field.



v4.0 | 93

PAXSTORE N.A. Reseller User Guideer Guide

> [Equal to] > 

Note: In this example ‘Equal to’ is selected.

> Modem Package Version [Drop Down Arrow] >

Note: This is a required field. 
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> select the desired [modem package] > [OK] to save the selection. A search field is also available to 
locate modem packages by file name.

Note: This example does not have sample data.
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13 .4.3.4  Terminal Activation Time

This filters allows the search to filter devices by terminal activation date from start to end date.

Select: [+Filer] > Filter Type: [Download Arrow] > [Terminal Activation Time] > Start Time [Calendar Icon] 
> [dd:hh:mm] > End Time [Calendar Icon] > [dd:hh:mm] > [OK] > [SAVE] to save settings. 

Select: [+ Filter] > Filter Type: [Download Arrow] 

> [Terminal Activation Time] > 
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> Start Time > [Calendar Icon] > 
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> [yyyy-mm-dd hh:mm] > [OK] > 

Note: In this example: 2022-04-15 19:30.
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> [End Time Icon] > 

> [yyyy-mm-dd hh:mm] > [OK] > 

Note: In this example: 2022-04-18 23:00.
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> [SAVE] to save settings.

> select the [Edit Icon] to edit the filter or the [Delete Icon] to delete the filter.
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13 .4.3.5 Merchant Type Filter

The Merchant Type Filter provides the ability to filter versions of merchant types to select from for 
download to the devices.

Select: [+Filer] > Filter Type: [Download Arrow] > [Merchant Type] > Method [Drop Down Arrow] > 
select desired Method [Method] > App Version [Drop Down Arrow] > select desired [Merchant Type] > 
[OK] > [SAVE]. 

Select: [+ Filter] > Filter Type: [Download Arrow] >

> select filter type [Merchant Type] >

Note: This is a required field.
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> select the Method type [Equal to] > 

Note: In this example, ‘Equal to’ was selected.

> select the Merchant Type drop [Drop Down Arrow].

Note: This is a required field.
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> select the desired merchant type [Retail] > [OK] to save setting.

Note: In this example, ‘Retail’ was selected.

> select [SAVE] to save the filter settings.
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> select the [Edit Icon] to edit the filter or the [Delete Icon] to delete the filter.

13 .4.3.6 Mobile Carrier Filter

The Mobile Carrier Filter provides the ability to filter versions of a mobile carries to select from for 
download to the devices.

Select: [+Filer] > Filter Type: [Download Arrow] > [Mobile Carrier] > Method [Drop Down Arrow] > select 
desired Method [Desired Method] > Please Select [Drop Down Arrow] > select desired [T-Mobile] > 
[SAVE]. 

Select: [+ Filter] > Filter Type: [Download Arrow] > 
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> select [Mobile Carrier] > 

> select Method [Drop Down Arrow] >

Note: This is a required field.
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> select the desired Method [Equal to] >

Note: In this example, ‘Equal to’ was selected.

> select the Please Select [Drop Down Arrow] > 

Note: This is a required field.
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> select the mobile carrier type [T-Mobile] > 

> select the [SAVE] to save the filter settings.

> select the [Edit Icon] to edit the filter or the [Delete Icon] to delete the filter.
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13.4.4 PUSH FAILED FILTER

A feature for Marketplace Owners and Resellers, a filter for the failed push for the terminals in the group 
push. Users can re-push the terminals based on specific error types. Users can select the 'Filter' icon and 
filter terminals by specific error types and re-push. 

13.4.5 ALL RESUME PUSH

A feature for Marketplace Owners and Resellers, a Gpush option called 'All Resume Push.' Users can select 
the 'All Resume Push' button to re-push all terminals filtered by specific error types.
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14. General Settings
The General Settings section includes a majority of the Marketplace and Reseller configuration settings. 
Depending on the Marketplace configuration and access restrictions, the configuration settings may vary 
and not be displayed.

14.1 Reseller Profile
When enabled, a feature in General Settings called Reseller Profile controls the Reseller General Setting 
menu display, and allows the Reseller to modify the profile. The Reseller Profile applies to all features 
under the Reseller.

• UI Setting - Enable the UI Setting for Reseller at General Setting.

• External System Integration - External System API Access is not enabled in this 
marketplace. The administrator can't enable the setting for resellers.

• RKI Setting - Enable the RKI Setting for a Reseller at Reseller Detail and General 
Setting

• Reseller Profile - If it is enabled, the reseller can modify the profile. Otherwise. 
only the marketplace administrator can modify the profile.

To access, select [General Setting] > [Marketplace Information] > Reseller Permission > UI Setting or 
External System Integration or RKI Setting or Reseller Profile.

14.1.1 FIRMWARE VERSION FILTER

The firmware filter allows the ability to select the version of firmware to download.

Select: Filter Type [Download Arrow] > [Firmware Version] > [Method Drop Down Arrow] > select desired 
Method option [Method] > [App Version Drop Down Arrow] > select desired application [Application] > 
desired application version [Application Version] > [OK] > [SAVE]. 

Select: Filter Type [Drop Down Arrow] > [Firmware Version] > 
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14.1.2 IMPORT MERCHANT TYPE

A Marketplace Owners and Reseller feature, “Import Merchant Type.” Previously administrators had to 
manually enter the ‘Merchant Type’ one by one. Now they can import in bulk, making it more efficient.

Select: [General Setting] > [Merchant Type] > [Import Icon] > [Import Merchant Type]. 

Merchant Type Template
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14.2 Choose Terminal Models
This Marketplace Administrator feature configures which terminals and devices are supported.

To access, select [General Setting] > [Model Management] > [Terminal Model] > [SAVE] to save settings.
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14.3 Enable Online Terminal Activation
Online Terminal Activation is a feature that enables or disables online terminal activation.

• If enabled, the terminal can be activated through the PAXSTORE API or at the 
terminal.

• If disabled, the terminal can only be activated at the terminal side. The Terminal 
ID must be provided when activating from the terminal side.

To access, select [General Setting] > [Marketplace Information] > Marketplace Setting > Online Terminal 
Activation > [ENABLE] > [SAVE].
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14.4 Featured Applications
A Marketplace Admin feature, the Marketplace home page has been redesigned, including a new section 
called “Featured.” When configured can display up to 9 featured applications. The setup for this feature is 
in General Settings.
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The feature is configured in General Settings > General Setting > Featured section > EDIT > + FEATURED 
APP > CLOSE.
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14.5 More Advertising Space
The Marketplace home page has been redesigned to provide more advertising space.

Note: Existing advertisement banners may require adjustments, and re-upload the banners to support 
the enhanced design.
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The advertising setup is accessed by [General Setting] > [UI Setting] > [Web Portal] > [Web Portal] > [Top 
Advertisement].

14.6 System Announcement
A Marketplace Administrator feature, System Announcement, will pop up and display automatically when 
the User logs in. The Marketplace Admin can choose developers, administrators and Users to receive the 
notifications. System Announcement history and status are displayed.

• Create a System Announcement to display as a pop-up window in the PAXSTORE. 

• Can target Developers, Marketplace Administrators, or Marketplace Users.

• The System Announcement uses the Push type configuration of when to send 
messages.

• Can send up to 3 announcements per day.

• The System Announcement includes Title and Body text sections. 
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14.6.1 CREATE A SYSTEM ANNOUNCEMENT

To access, select [General Setting] > [Advance Setting] > System Announcements > 

[+ ANNOUNCEMENT].
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Next, a Send System Announcement window will pop up. Enter the [Title] > [Body] and then set the Push 
Immediately, Time Zone, Expired Date, and who will receive the message values. Select CANCEL to cancel, 
PREVIEW to view, SAVE to save the message, or [PUBLISH] to publish the message.
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When the designated User logs in, the System Message will display.
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14.6.2 EXTERNAL SYSTEM INTEGRATION

A Marketplace Owners and Marketplace Owners and Marketplace Owner feature, an email notification is 
sent when an administrator resets the 'External Access Secret' used for an external API. After the 'External 
Access Secret' is reset, the relevant administrators will be notified by email.

Select: [General Setting] > [External System Integration] > [External System Integration].
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14.7 Two-Factor Authentication
Added two-factor authentication settings at the marketplace level to provide higher security. Once 
enabled, only Users who have set up two-factor authentication will be able to login into the admin center.

Note: Must enable Two-Factor Authentication in the Personal Center.
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14.8 Sensitive Content
Added a new feature for sensitive content filtering under CloudMessage. 

• The marketplace administrator can configure the sensitive content dictionary in 
'General Setting' -> 'Advance Setting.' Once uploaded, all the sensitive content 
send via CloudMessage will be replaced with “***.”

• For example, suppose there is a sensitive word “ABCD” in the uploaded 
sensitive content dictionary. The developer sends a message containing 
“ABCD” via CloudMessage when the terminal receives the message. In that 
case, the sensitive word “ABCD” will be replaced by “****.” 

15. Audit Log
The Audit Log is a section that displays and can download reports on using Operations and Login 
attempts. Both sections include ALL, SUCCESS, and FAILURE categories for display and export. A search 
filter is available to concentrate the report further. Some filters, when selected, will display additional 
sub-filters.

List of Audit Log filters:

• Developer

• Search by Developer 
Email

• App

• Search by Package 
Name

• Firmware

• Search by Firmware 
Name

• Terminal

• Search by SN
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• Terminal Group

• Search by Group Name

• Push App

• Search by SN

• Push Firmware

• Search by SN

• Push RKI

• Search by SN

• Group Push App

• Search by Group Name

• Group Push Firmware

• Search by Group Name

• Group Push RKI

• Search by Group Name

• Group Push Message

• Search by Group Name

• Group Push Uninstall App

• Search by Group Name

• Parameter Template

• Search by Push 
Template Name

• Parameter Variables

• Search by Parameter 
Variables

• Sandbox Terminal

• Search by SN

• Sandbox Push App Param

• Search by Package 
Name

• Estate

• Search by Estate

• Merchant

• Search by Merchant 
Name

• Reseller

• Search by Reseller 
Name

• Model

• Search by Model Name

• User

• Search by Login Name

• User Roles

• Search by Name

• System

• Search by Time

• Release Note

• Search by Time

• AirViewer

• Search by SN

• Report

• Search by Report 
Name

• Announcement

• Search by Time

• Store Client

• Search by App Name

• Search by Time

• Search by Login Name
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16. Service Center
The Service Center section includes the Subscribed Services. The Subscribed Services are add-on 
applications or services available by subscription. Each Subscribed Service has sub-menus to support 
Current Month distribution reports. A History report to show how often and how long the service is 
connected. An Introduction can provide a summary story and images to support the service and subscribe 
to the service. 

A Marketplace Administrator-level feature is the ability to enable selected Resellers to offer the 
Subscribed Service. 

To access, select [Service Center].
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16.1 AirViewer Optimization 
Added the ‘Unattended Model Configuration” feature for AirViewer. In previous versions, the unattended 
model was restricted to IM30, SK600, SK800 and could not be changed; Now, the Marketplace 
administrator can define these terminal models as “Attended models” via the AirViewer service setting. 
For more information, please refer to the AirViewer release note document. 
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16.2 Subscription Optimization 
The position of the ‘SUBSCRIBE’ button is improved. It has been moved to the top right corner of the page 
so that Users can see it at a glance. 

 

Optimized the page layout and integrated some small features into the drop-down menu in the upper 
right corner.
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16.3 Service Distribution
Added a new feature in Service Distribution to distribute service to selected resellers within the 
Marketplace.

To access, select [Service Center] > desired [Subscribed Service] > [Service Distribution] > [+ SERVICE 
DISTRIBUTION].

Note: The Subscribed Service must be subscribed, to use this feature.
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Select [Resellers] > [SAVE].
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16.4 AppScan Service
AppScan is a professional online application security scanning service that helps developers find 
application risks, provides a reference for the administrators when approving applications, and enhances 
the platform’s security.

16.5 Subscribed Services Include Sub-Resellers
A Marketplace Admin feature is the ability to include Sub-Resellers in results.

To access, select [Service Center] > Subscribed Services > [AirViewer] > [Include Sub-Resellers].
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17. Developer Center
The developer center is where the software developers can register and submit terminal applications to 
be available within the PAXSTORE.

17.1 Developer Agreement
The Developer Agreement is located in the Personnel Center. Must be in Developer Mode.

To access select [Development Center] > [User Name] > [Developer Agreement] > [OK].
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17.2 Developer Center Application Version Total Count
Added a new feature in the App Detail section that displays the total number of application versions. 

To access, select [Developer Center] > [App Management] > Application > App Detail.

17.3 Disable Debug Application Submission
A Global feature can enable or disable debug application submission. If the feature is disabled and a 
Developer attempts to submit a debug application, a message will display as “Unable to so submit debug 
mode application.”

18. Subscription List
18.1 Removed Installation Package Information
In the [Subscription List] > [App Detail] > removes the Installation package information and download 
link.

19. Terminal Management
19.1 Add Sub-Reseller
The add Sub-Reseller feature allows the Reseller to add, edit, or delete a sub-reseller. The Reseller cannot 
add, edit or delete a Reseller. The Reseller is added, edited or deleted by PAX. Sub-Resellers can add, edit 
or delete their merchants. 

The Add Sub-Reseller option is located within the Reseller Administration level in the Terminal 
Management category and within the + SUB-RESELLER link option. 
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19.1.1 STEP 1. LOGIN TO THE RESELLER LEVEL

From the PAXSTORE home page, select the [LOGIN] icon in the upper right-hand corner of the page and 
log in. If the login is successful, the GLOBAL MARKETPLACE page will open.

19.1.2 STEP 2. SELECT THE RESELLER ADMINISTRATOR ICON

From the GLOBAL MARKETPLACE page, select the Multi-Link icon and then select the Reseller 
Administrator icon. 
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19.1.3 STEP 3. SELECT THE TERMINAL MANAGEMENT CATEGORY

From the left side of the page, select the [Terminal Management] category.

19.2 Add Merchant
The Add Merchant feature allows the Reseller Administrator to add, edit or delete a merchant. A 
merchant must be added or already existing before a terminal download assigned to the merchant is 
performed. A merchant must be assigned to a reseller or sub-reseller. 

The Add Merchant option is located within the Reseller Administration level in the Terminal Management 
category and under the + MERCHANT link option. 

19.2.1 STEP 1. LOGIN TO THE RESELLER LEVEL

From the PAXSTORE home page, select the LOGIN icon in the upper right-hand corner of the page and log 
in. If the login is successful, the GLOBAL MARKETPLACE page will open.
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19.2.2 STEP 2. SELECT THE RESELLER ADMINISTRATOR ICON

From the GLOBAL MARKETPLACE page, select the Multi-Link icon and then select the Reseller 
Administrator icon.

19.2.3 STEP 3. SELECT THE TERMINAL MANAGEMENT CATEGORY

From the left side of the page, select the [Terminal Management] category.

19.2.4 STEP 4. ADD A NEW MERCHANT SELECT THE + MERCHANT LINK

From the right-side area of the page, select the [+ MERCHANT link. A new Create Merchant Pop-up 
window will appear.
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19.2.5 STEP 5. CREATE A NEW MERCHANT PROFILE

From the center of the page, a Create Terminal pop-up window will appear. There are required and 
optional fields. Please complete all required fields and include the optional fields as needed. Select the 
[OK] button on the bottom-right hand corner or select CANCEL to exit without saving when complete and 
ready to save. If any of the required fields are incomplete, a red text message will be displayed on the 
impacted field when [OK] is selected. 

These fields include: 

• Merchant (required)

• Login Name/Email Address (required)

• Select the Reseller Name (required)

• Select the business type (required)

• Contact Name (Required)

• Phone No. (required)

• Postal Code

• Address (Required: Country, State/Province, City)

• Description
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Create Merchant—Top Section

Complete the Create Merchant form. The required fields must be completed. To activate the merchant, 
immediately select [Activate Merchant] > [OK] to save.
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Create Merchant— Merchant Type

Selecting the Merchant Type drop-down menu displays the Merchant Type pop-up window. The 
Merchant Type sets the merchant type of business such as restaurant, retail, or petroleum.

Select [merchant type] > [OK].
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19.2.6 STEP 6. MERCHANT DETAIL

After selecting [OK], the Merchant Detail screen displays. In this screen, the merchant details are 
displayed. The ability to edit, disable, or delete the merchant is available when this option is opened by 
selecting the “More Options” icon on the upper right-hand side of the merchant detail page.

Merchant Detail Options

• Edit—The ability to edit the merchant detail fields. Login name/email address 
field edit is not allowed.

• Disable—Disables the merchant but does not delete the merchant.

• Change User—This is only displayed if the profile is “Active.” Allows the ability to 
change the merchant login name/email address.

• Delete—Is only displayed if the profile is Inactive. If selected, can delete the 
merchant profile.
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19.3 Import Merchants
The Import Merchants is a feature that includes the ability to import Merchants in the Reseller 
Organization section. The Merchant Import feature can significantly reduce time in adding new 
merchants.

19.3.1 IMPORTING MERCHANTS

From the Category section select [Terminal Management] > [desired Reseller] > [Organization] > 
[Merchant] > [Import Icon] > [Import Merchant].
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19.3.2 IMPORT MERCHANT TEMPLATE

After selecting Import Merchant, the Import Merchant pop-up window will display. Select [TEMPLATE] to 
download the Import Merchant template file.

19.3.3 IMPORT MERCHANT TEMPLATE FILE

After the Import Merchant Template file has downloaded, locate and open the file.

The following fields are supported:

• Merchant Name - The name of the Merchant business.

• Login Name - The email address of the person responsible for the Merchant.

• Reseller - Select from the drop-down list of resellers the merchant is related to.

• Merchant Type - In the Edit Merchant pop-up window, the Merchant Type field 
has a drop-down menu to select the supported values. Please copy the 
appropriate merchant types supported and paste them into this field.

• Contact Name - The merchant’s contact person’s name.

• Phone No. - The merchant’s contact phone number.

• Country/Region - Select the country or region from the drop-down options list 
where the merchant business is located.

• State/Province - Select the state or province from the drop-down options list the 
merchant is located.

• City - Enter the city where the merchant is located.

• Postal Code - Enter the postal code of the merchant location.

• Address - Enter the physical address of the merchant location.
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• Status - Select from the drop-down menu whether the merchant will be active or 
inactive.

• Create Merchant User Account - Not yet supported.

19.3.4 IMPORT MERCHANT FILE TEMPLATE

When the Import Merchant Template file is ready select [Terminal Management] > [desired Reseller] > 
[Organization] > [Merchant] > [Import/Export Icon] > [Import Merchant]. 
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After Import is selected, a pop-up window Import Merchant will display. Select [Import Icon] then locate 
and select the [Merchant Import Template file] > [OK].

19.3.5 SUCCESSFUL MERCHANT FILE IMPORT

When the file is successfully imported a pop-up message will display the number of successful imported 
merchants and the successful imported merchants will display in the related Organization Merchant List.

19.3.6 UNSUCCESSFUL MERCHANT FILE IMPORT

If there are any unsuccessful line items in the import file, please resolve the failed field values and import 
the file again until successful. 
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19.4 Add, Edit, or Delete a Terminal
This feature includes instructions on how to add, edit or delete a terminal. The reseller and merchant 
assigned to this terminal must be created before adding a terminal. The terminal profile must be created 
before attempting to download from the PAXSTORE. It is possible to download a terminal without the 
serial number or TID number but not without both numbers.

19.4.1 CREATE TERMINAL PROCESS

We have optimized the process of creating terminals. The terminal model is no longer mandatory when 
the terminal is created. The administrator can set the terminal model when the terminal is activated. If 
the PAXSTORE client is used to activate a terminal, it will automatically set the terminal model during 
activation if the terminal model type is not already configured.
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19.4.2 STEP 1. SELECT THE TERMINAL MANAGEMENT CATEGORY

To access: Select [Terminal Management] > [Reseller/Sub-Reseller/Merchant]. 

Note: To expand the category tree select the [Expand Icon] in the bottom left corner.
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19.4.3 STEP 2. SELECT THE TERMINAL LIST OPTION

Select: [Terminal List] to display terminals assigned to the selected Reseller or edit or add new terminals.

19.4.4 STEP 3. ADD A NEW TERMINAL 

Select: [+ CREATE TERMINAL]. A new Create Terminal pop-up page will appear.

19.4.5 STEP 4. ADD NEW TERMINAL INFORMATION

In the CREATE TERMINAL window, please complete all required fields and include the optional fields as 
needed. When complete and ready to save select [OK] or select CANCEL to exit without saving. If any of 
the required fields are incomplete a red text message will be displayed on the impacted field when [OK] is 
selected. Edit these fields as needed until correct. 



v4.0 | 145

PAXSTORE N.A. Reseller User Guideer Guide

Note: A terminal TID will be automatically created if the serial number is not entered during the terminal 
setup. The terminal ID (TID) can be entered when configuring the terminal to register with the PAXSTORE. 

The terminal setup fields include:

• Terminal Name - Create a name for the terminal.

• Quantity - Enter the number of terminals to be added.

• Activate Terminal Later - When selected, the terminal can be activated at a later 
date.

• Activate Terminal Immediately - When selected, and the terminal will be 
activated immediately.

• Serial No. - Enter the 1st sequential serial number.

• End Serial No. - Will automatically be incremented based upon the quantity 
value entered. This field is only displayed if the Quantity field value is two or 
more.

• Manufacture - Select the terminal manufacture from the drop-down menu.

• Model - Select the terminal model from the drop-down menu.

• Reseller - Will auto-populate or select from the drop-down menu.

• Merchant - Select the merchant the terminals will be assigned to from the drop-
down menu.

• TID - Enter the PAX terminal ID. This TID is not the processor terminal ID.

• Location - Optional field to enter the location of where the terminal will be used.
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To access, select [Terminal Management] > [Reseller or Sub-Reseller or Merchant] > [Terminal List] > [+ 
TERMINAL] > Create Terminal.
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19.4.6 STEP 5. TERMINAL LIST

After creating the terminal profile and selecting [OK], the new terminal information is displayed in the 
Terminal List column.

19.5  Delete, Activate, Disable, or Export Terminal Details
To view, move, add to a group, activate, delete, or disable a terminal profile, select the box next to the 
terminal(s) to be impacted and select the option.
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Selecting the Export option will download an excel spreadsheet with the terminal detail information. 

19.5.1 TERMINAL BATCH IMPORT

A feature for Marketplace Owners and Resellers to move, disable, and delete multiple terminals by 
importing files. 

Previously, if a user has a batch of terminals that needs to be managed, they have to find the terminals 
one by one, which is very inefficient. Now the user can import a list of terminals, which is more 
convenient. The steps are as follows (taking 'Disable Terminal' as an example).

Select: [Import/Export icon] in the terminal list tab. 
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Select: [Disable Terminal] menu to upload the file containing the terminals which are to be disabled. To 
download the Disable Terminal Template select the [TERMINAL TEMPLATE] option. 

Select [OK] to save.

Sample File
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If there are validation errors, the user will need to correct these and upload again.

If there are no validation errors, all terminals provided on the import file will be successfully disabled. See 
sample disabled terminal. 
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19.5.2 TERMINAL SEARCH FILTER BY CREATED OR ACTIVATION TIME

A feature, for Marketplace Owners and Resellers, two search filters in the 'Terminal List'. Users can filter 
terminals by created time or activation time in the terminal filter list. 

Select: [Terminal Management] > [Terminal List] > [Filter Icon] > [Created Time] > 
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The CREATED TIME and ACTIVATION TIME will display. Select the [Desired Option] and then select the 
[Start Time] and [End Time] options and set as needed.
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19.5.3 TERMINAL QUICK SEARCH

For Marketplace Owners and Resellers a terminal 'Quick Search' field is available to help the user quickly 
search for a terminal. Users can find the 'Quick Search' icon in the top right corner of any page. This 'Quick 
Search' function only supports an exact matching of a serial number. 
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When a matching record is found, it will jump to the 'Terminal Details' page. 

19.5.4 TERMINAL FILTER REPORT

In the Terminal Filter report on the Terminal List page, three-terminal filters were removed; Installed App, 
Push Status and Out of Geo-Fence. 
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19.5.5 STEP 1. TERMINAL DETAILS

To review and edit terminal details, select the [terminal].

19.5.6 STEP 2. BASIC TERMINAL INFORMATION TAB

After selecting the terminal name, the basic information will display by default. If the terminal has synced 
up with the PAXSTORE, then the terminal information will be displayed. If the terminal has not synced up 
with the PAXSTORE, then the terminal information will not be displayed. 

Top Banner Section Fields and Features Displayed: 

• Terminal Name

• Serial Number

• Terminal ID (TID)

• Reseller Name

• Merchant Name

• Location

• Terminal Status

• More Options Icon (Edit, Enable, Disable)

• Basic Information Tab 
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• App & Firmware Tab

• Settings Tab

Dashboard Section

• Terminal Monitor (CPU, RAM, Storage)

History Section

• List of Operator activity with the terminal

Bottom of Page Section

• Items/page and page number

Technical Details Section

• SN (Terminal Serial Number)

• Model

• Android Version

• IMEI

• Screen Resolution

• Language

GPS Location Section

• Displays GPS map location of the terminal. The terminal must be powered on for 
GPS information to display.

Top Portion of the Terminal Basic Screen
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Bottom Portion of the Terminal Basic Screen

19.5.7 STEP 3. APP & FIRMWARE TAB

The APP & Firmware Tab provides information regarding installed firmware, firmware version, 
applications, source of applications, third-party applications, system applications, cellular data, push 
application, push firmware, push application, and firmware configuration. There is also a manual sync 
icon button and an additional sort option for the installed applications.

Top Banner Section Fields and Features Displayed:

• Terminal Name

• Serial Number

• Terminal ID (TID)

• Reseller Name

• Merchant Name

• Location

• Terminal Status

• Options Icon (Edit, Enable, Disable)

• Basic Information Tab

• App & Firmware Tab

• Settings Tab

Installed Firmware Section

• Displays installed firmware name and version information currently installed in 
the terminal.
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Application and Firmware Add and Push Section

• Push App—when configured, it will push selected applications and parameters to 
the terminal.

• Push Firmware—when configured, it will push firmware to the terminal.

Installed Apps Section

This section is a report of the installed applications with various sort options. 

Sort Options:

• ALL

• APP STORE

• THIRD-PARTY

• SYSTEM APP

• ONLY CELLULAR DATA (how much cellular data usage)

Additional Sort Options with the SORT tool:

• Sort by App Name

• Sort by App Source

• Sort by App Size

• Sort by Install Date

• Sort by This Month Data

• Sort by Today Data

Matrix Titles:

• #

• APP

• SOURCE

• SIZE

• INSTALLED TIME

• THIS MONTH DATA

• TODAY DATA ACTION
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The App and Firmware Tab

19.5.8 STEP 4. PUSH APPLICATION

Pushing an application means a feature within the PAXSTORE to support adding an application into the 
terminal profile to be pushed to the designated terminal or terminals. Selecting the + PUSH APP option 
sets up the PAXSTORE to push an application. 
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19.6 Terminal Application Download with a TID
The PAXSTORE is a cloud-based management platform for terminal and application management. The 
main functions include application edit, developer edit, terminal maintenance, parameter configuration, 
application & parameter push, firmware maintenance, firmware push, and reports of terminals. The 
Administrator can maintain the manufacturer, model, reseller, and merchant reports of terminals and 
implement terminal group management on this platform. 

The administrator can push applications, parameters, and firmware to a specific terminal or one terminal 
group through the terminal management system. They can also view reporting of a particular terminal, 
installed application list, installed firmware, and terminal hardware status.

19.7 Download Instructions for the Terminal
This document assumes the PAXSTORE is currently configured for a reseller, includes terminal 
manufacture and terminal model information and this instruction is to add a new merchant and terminal 
for a download. Please note that only the reseller information, reseller-supported merchants, terminals, 
and applications are available within the reseller’s store.

19.7.1 STEP 1. ADD NEW TERMINAL

To set up a terminal for download, the terminal information must be added to the PAXSTORE. To add a 
new terminal, please log into the PAXSTORE. Note that only an Administrator-level can add terminals. 
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19.7.2 STEP 2. SELECT ADMINISTRATOR CENTER

Once logged into the PAXSTORE. select [Administrator Center] on the upper right-hand corner area of the 
page.

19.7.3 STEP 3. SELECT TERMINAL MANAGEMENT CATEGORY

From the category tree on the left side of the page, select the [Terminal Management] category.
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19.7.4 STEP 4. SELECT A RESELLER ACCOUNT

Next, from the Marketplace category tree on the left side of the page select the [Reseller] account to use 
the terminal.

19.7.5 STEP 5. SELECT + CREATE

To create a new terminal account, select [Terminal List] > [+ TERMINAL].
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19.7.6 STEP 6. SELECT OK TO SAVE

The terminal setup page includes the following fields: Terminal Name, Quantity, Activate Terminal, 
Manufacture, Model, Reseller, Merchant, SN, END SN, Location, CANCEL, and OK. Required fields must be 
completed. Then select [OK] to save or CANCEL to exit without saving.
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19.7.7 STEP 7. NEW TERMINAL LISTED

After submitting the terminal information, the new terminal will appear in the terminal list. 
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19.7.8 STEP 8. ACTIVATE A TERMINAL

Activating a terminal profile will enable the terminal to access the PAXSTORE with the PAXSTORE Client 
application and register the terminal. Select the box next to the terminal information and then select the 
Activate button on the bottom right side of the page. Until the terminal is activated and registered, the 
terminal will display an error message on each attempt to register with the PAXSTORE. The error message 
displayed on the terminal is “Login failed, terminal (SN:nnnnnnnnn) not registered” and the merchant will 
have to contact customer support to resolve the issue.

19.7.9 STEP 9. TERMINAL READY TO REGISTER

Now the terminal is ready to register the PAXSTORE Client with the PAXSTORE. Once the terminal is 
successfully registered, the PAXSTORE Client will display on the terminal the available applications in the 
PAXSTORE. During terminal registration, the terminal will include the terminal serial number and terminal 
details to the PAXSTORE. After successful registration, the merchant can manually select an application 
from the terminal and manually initiate the download from the terminal. 

In addition, the terminal profile can be configured for an application or firmware to be pushed to the 
terminal from the PAXSTORE side. 
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19.7.10 STEP 10. SETUP APPLICATION OR FIRMWARE

To set up an application or firmware to be automatically pushed to the terminal, select [Terminal 
Management] > [Terminal List] > [Terminal] > [App & Firmware] > [+PUSH APP]. 
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19.7.11 STEP 11. SELECT AN APPLICATION

To setup an application to be pushed to the terminal select an [Application] from the Add Push 
Application list and then select [OK]. 
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19.7.12 STEP 12. SELECT EFFECTIVE TIME

In the Push Time menu, select the [EFFECTIVE TIME] calendar option.
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19.7.13 STEP 13. SELECT DATE AND TIME

Select the date and time using the calendar, then [OK] to save or select the [NOW] option.
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19.7.14 STEP 14. TO ACTIVATE SCHEDULED DOWNLOAD PUSH

To activate the scheduled download push, in the Application Package/Push Time section, select 
[ACTIVATE].

19.7.15 STEP 15. PUSH DETAIL SCREEN

To view the push application status, see the Push Detail screen.
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19.7.16 STEP 16. VIEW TERMINAL DETAILS

To view terminal details such as installed applications and pushed application status select [Terminal 
Management] > [Reseller] > optional [Sub-Reseller/Merchant] > [Terminal List] > select desired 
[Terminal].
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19.7.17 STEP 17. VIEW TERMINAL TYPE, BRAND, SERIAL NUMBER, ETC.

Scroll on the Terminal Detail page to view the terminal details, such as terminal type, brand, model, serial 
number, installed applications, pushed application, terminal status, and more.
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19.8 Terminal Parameters
The PAXSTORE supports the ability to include a separate parameter file with the application download. 
The parameter file is created, maintained, and assembled per the developer to support their application. 
Below is a sample image of the parameters. 
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19.9 Import Variable Terminal ID
The Import Variable option previously required the serial number to import variables to terminals. Now it 
is possible to import variables to a terminal as long as the TID is provided. The serial number has higher 
priority, and the TID is only used when the serial number is not available.

Note: The TID is the PAX terminal ID number and not the processor TID.

The Status field supports adding “D” to ignore the line item during import.

19.10 Parameter Files Comparison
A Marketplace Owner and Reseller feature to compare parameter push histories. Previously users could 
not compare the parameter differences in the parameter applications two push histories. Now users can 
select two push histories in the ‘Operation History’ section and compare the parameter differences. 

Note: The comparisons only show the differences. Passwords will not be compared.

Please see the steps below:

Step 1: Select: [Terminal Management] > desired [Reseller] > desired [Terminal] > [App & Firmware] > 
[Push App] > Operation History > [Compare icon].
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Step 2: Select two push histories for comparison.

Step 3: View the differences between the parameters.
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19.10.1 TERMINAL INITIALIZATION

A Marketplace Owners and Reseller feature. When the user initializes the terminal, the platform will 
automatically correct the model information set on the platform according to the actual model 
information of the terminal. For details, please refer to the following example:

Example:

The user has registered a terminal, but it is not yet activated. Reseller: Mars Test, Merchant: Orange, SN: - 
TID: 88888888, Model: A930.

Requirement: Client version is equal to or greater than 8.0.
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The reseller provided a new terminal SN: 08******07, Model: A920 and the initialization operation was 
performed. 
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After the initialization is successful, the terminal model information was changed from A930 to A920 on 
the ‘Terminal Details’ page.
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19.10.2 TERMINAL INITIALIZATION ERROR MESSAGE

A Marketplace Owners and Reseller feature to display an error message “Terminal model mismatch”. This 
occurs when an Android device TID is registered as a legacy device and the TID is manually entered into 
the device.

Note: Only supported on Android devices.
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19.10.3 TERMINAL REPLACEMENT

A Marketplace Owners and Reseller feature that allows users to use different model terminals when 
replacing terminals. Previously when replacing terminals, users could only use the same model terminals. 
Now users can use other model terminals for replacement, the platform will automatically update the 
related model info according to the upload information of the new terminal. For details, please refer to 
the following example:

Example:

There is something wrong with the user's terminal (Reseller: Mars_Test, Merchant: Orange, SN: 
08******07, TID: 110110110, Model: A920).

Requirement: Client version is equal to or greater than 8.0.
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The reseller provided a new terminal, SN: 16******68, Model: A620, and performed the replacement 
operation.
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After the replacement was successful, the terminal model information was changed from A920 to A620 
on the ‘Terminal Details’ page.

19.10.4 SIMM OPERATOR DISPLAY

A feature for the Marketplace Owners and Resellers, which is a field called 'SIM Operator' located in the 
'Technical Details' part of the 'Terminal Details' page. This displays the SIM card information. The device 
must have an activated SIM installed in the device to display the SIM service provider  information. 

Select: [Terminal Management] > [Reseller] > [Terminal] > Technical Details > SIM Operator
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19.10.5 PUK UPDATE

A Marketplace Owners and Reseller feature to view the PUK push history. Users can view the detailed 
push history by clicking on the ‘Push History’ menu on the right of 'PUK Certification Detail.' 
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19.10.6 CREATE TERMINAL REMARK FIELD

A Marketplace Owners and Reseller feature, a ‘Remark’ field in the ‘Create Terminal’ page. The Users can 
now fill in custom content in this field. 

Select: [Terminal Management] > desired [Reseller] > [Terminal List] > [+ TERMINAL].
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19.10.7 MODEM INFORMATION DISPLAY

A Marketplace Owners and Reseller feature to display the modem package information on the terminal 
detail page. 

Select: [Terminal Management] > desired [Reseller] > desired [Terminal] > [App & Firmware] > Installed 
Firmware > Modem package information.
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19.10.8 TERMINAL LIST DEFAULT

An enhancement for the Marketplace Owner and Reseller is the Terminal List is now displayed by default 
when the Terminal Management section is selected.

Select: [Terminal Management] > [Reseller] > view Terminal List.
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19.10.9 SEARCH OPTIMIZATION

The Terminal Search feature has been optimized for the Resellers. The terminal search feature defaults to 
the terminal serial number, optional search tools include the terminal TID and terminal name. The 
terminal search optimization is implemented in all terminal search locations in Terminal Management and 
Group Management sections.

Select: [Terminal Management] > [Reseller] > [Terminal List] > [Search].

Selecting the terminal search drop down arrow displays the terminal SN, TID, and Name search options.
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The terminal search by filter option also defaults to serial number.

Select: [Terminal Management] > [Reseller] > [Terminal List] > [Search Terminal Filter].
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Select the terminal serial number drop down arrow to display the search by terminal Serial Number, TID, 
and Name options.
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19.10.10 TERMINAL SEARCH BY SERIAL NUMBER

For Marketplace Owners and Resellers, The left and right matching will replace the existing fuzzy search. 
For example, the SN “S1234567N”, will now search using ‘S123’ or ‘567N’, but not ‘12345’. 

Select: [Terminal Management] > [Reseller] > [Terminal List] > [SN Search] > [nnnn] > [Search Icon].
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19.11 Terminal Geo-Fence
The Terminal Geo-Fence feature tracks the terminal location. The Terminal Geo-Fence can provide 
location status reports to show any terminals outside of the designated geo-location zone.

To access the Geo-Fence parameters select [Terminal Management] > [Reseller/Merchant] > [Profile] > 
see Terminal Control.

19.11.1 GEO-FENCE

When the Geo-Fence parameter is enabled, the system will alert when the terminal is outside of the geo-
fence. It only works for the terminals to which the geo-fence is defined.

19.11.2 AUTO SET CENTER POINT

When the Auto Set Center Point parameter is enabled, it automatically sets the current terminal position 
as the center point of the geo-fence. 

19.11.3 GEO-FENCE SAFETY RADIUS

This parameter sets the Geo-Fence radius for the terminals. The center point of the geo-fence can be 
configured on the terminal detail page. 2000-9999999 meters.
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19.11.4 GEO-LOCATION DATA UPLOAD

For Marketplace Owners and Resellers, the parameter enables or disables the terminal location report. 
The Location Data Upload parameter is located in the 'Profile' section of the 'Reseller Detail' page.

Select: [Terminal Management] > [Reseller] > Terminal Control > [Location Data Upload] > [Enable].
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19.11.5 TERMINAL LOCATION 

When “Location Data Upload” for terminals is disabled in the “Profile” page, previously, the last uploaded 
Geolocation of a terminal was still displayed. Now, the location data of all terminals will be cleared and, a 
message “Terminal Location Not Uploaded” will be displayed in the terminal location section of the 
“Terminal Details” page. 

Added a refresh feature in the terminal location dashboard. Users can use this to get the real-time 
location of the terminal. When the User clicks on the refresh button, the current location data will be 
cleared, and the new location of the terminal will be retrieved.



v4.0 | 194

PAXSTORE N.A. Reseller User Guideer Guide

19.11.6  WI-FI OR ETHERNET ONLY FOR PUSH TASK

When enabled, this feature will only allow a Push Task to occur when the device is connected with a Wi-Fi 
or Ethernet connection and does not allow the Push Task over the wireless cellular data connection. 
When disabled, a Push Task can occur over a cellular data connection.

To access, select [Terminal Management] > [Reseller or Sub-Reseller or Merchant] > [Terminal List] > 
[desired Device] > [+ PUSH APP] > [desired Application] > [Push Configuration] > [Wi-Fi Only] > [Enable] 
> [ACTIVATE].

19.12 Wi-Fi Configuration
This feature allows configuration of the Reseller, Sub-Reseller, and Merchant location Wi-Fi configuration 
settings. Each time the terminal PAXSTORE Client application contacts the PAXSTORE, the terminal is 
updated with new or edited settings.

IMPORTANT NOTE: Be careful in the setup. The higher hierarchy has priority. If the reseller is enabled to 
set the Wi-Fi configuration, it will overwrite all other lower Wi-Fi settings.
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In [Terminal Management] > [Reseller or Sub-Reseller or Merchant] > [Profile] > [Terminal System 
Configuration] > [Wi-Fi] > [Wi-Fi icon] to open the configuration window.

The Wi-Fi Configuration pop-up window will display. Select [+ CONFIGURATION].
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A new Wi-Fi window will display. Enter the [SSID Name] > [Security Type] > [Wi-Fi Password] > [Wi-Fi 
Password] > [OK] to save.
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19.12.1 WI-FI PASSWORD

In the Terminal Management Reseller Profile section, a Reseller feature, the Wi-Fi password increased the 
length from 16 bytes to 63 bytes.

Select: [Terminal Management] > desired [Reseller] > [Profile] > Terminal System Configuration > Wi-Fi > 
[Wi-Fi Icon].

You
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19.13 Wi-Fi Proxy
A proxy setting in the Wi-Fi configuration. Previously the proxy had to be configured at the terminal 
offline. Now Users can directly configure the proxy under the Wi-Fi configuration in the Profile settings. 
There are two ways of configuring the proxy: 

• Manual: The User needs to configure the proxy host and port manually.

• Proxy Auto-Config: The User only needs to configure the Pac URL, like https://
www.example.com/proxy.pac.
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19.14 Password Policy
Is a password policy for the “Terminal Setting Password.” When setting passwords in “Profile”, the 
password must contain at least seven digits, including three numbers, three letters, and one special 
character. The password must be a minimum of 7 to a maximum of 32 characters. This change is because 
the password policy on the new firmware for many terminals has changed, so the same rules must be 
applied when setting the password on the 'Profile' page.
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19.15 Terminal Logcat
Added a new feature, “Collect Detailed Log.” In addition to the original logcat, Users can now get a more 
detailed log which helps them better analyze and resolve problems.
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19.16 Resource Package Display
Added a new feature to display resource packages. In the “Installed Firmware” section, we have added a 
subtitle below the firmware package name to show the resource package name installed in the terminal.
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19.17 Merchant Search
Added a new feature to allow searching of merchants by description as well as by merchant's name.

19.18 Edit Language
A feature that supports editing Language is available in Terminal Management > Terminal Detail > Setting 
> Terminal System Configuration > Language. When the option is changed, the terminal will be updated.
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19.19 Parameter Template 
Added the ability for Users to clear the password type field in the parameter template. Previously Users 
could not set the value to null for the password type field, and now it can be cleared by clicking on the 
'delete' icon.
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19.20 Merchant Center
Added a new 'Merchant Center' function. The Merchants Portal allows merchants to view their specific 
data such as online and offline terminals, model distribution, purchased Android applications, etc.

• The merchant can use the URL https://
your_marketplace_domain.www.paxstores.com/merchant to log in directly to 
the Merchant Portal.

• If the Marketplace is subscribed to the GoInsight service, the merchant can also 
access custom dashboards defined in the GoInsight system. 
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19.21 Alerts
• Added a new 'Alert' function. Users can define specific rules for an alert event, 

and when the alert event triggers, the specified receiver will be notified. In 
addition to providing standard alerts, if a User is subscribed to GoInsight, they 
can set up advanced alerts via GoInsight.

• Basic Alert: Provides some real-time triggered alerts. The trigger rules have 
been predefined, and a User can edit the receive method and receiver;

• App Signature Failed: An alert when the application signature fails. 

• Out of Geo-Fence: An alert when a terminal goes outside geo-fence. The 
alert works for terminals for which a Geo-Fence has been defined.

• Printer Out of Paper: An alert when the printer is out of paper. The alert 
works only when the terminal printer is enabled.

• GoInsight Alerts: If a User is subscribed to the GoInsight service, more advanced 
alerts are available.

• Users can edit, suspend and delete the existing alerts.

• Users can also create new alerts.

• Select an alert type first such as “Terminal Cellular Alert,” “Terminal 
Bright Screen Alert,” “Battery Usage Alert,” “AirViewer Usage Alert.”

• Edit the alert information, like “Alert Name,” “Alert Rule,” “Calculation 
Time,” and “Message.”

• Save and activate.

• Five alerts can be created for each alert type, and up to 20 alerts can be 
made in total. 
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19.22 Display Language
The terminal language is displayed in Terminal Management > Terminal Detail > Basic Information > 
Technical Details section.
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19.23 Phone Number
There is a Phone Number field in the Terminal Detail > Technical Details section. If a phone number is 
obtained from the terminal, it is displayed in the field. This information is generally for cellular use.
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19.24 Terminal Detail Fields
There are two fields in the Terminal Details section as Reseller Certificate and Location. If this information 
is available from the terminal, it will be displayed.
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19.25 Send Message
In the Terminal Detail or Group Management sections, a feature supports sending messages to a terminal. 
The message includes a Title line and a Message Body.

19.25.1 TERMINAL MANAGEMENT TEXT MESSAGE

To access: [Terminal Management] > [Reseller Name] > [Terminal List] > [Terminal] > [Setting] > [SEND 
MESSAGE].

19.25.2 GROUP MANAGEMENT TEXT MESSAGE

A text message can be send to 1 or more terminals in a single push using the Group Management option.

A group will need to be created or use an existing group to assign the Group Message. 

To access: [Group Management] > [Group Type] > [Group Name] > [Push Task] > [Push Message] > [+ 
PUSH MESSAGE].
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After selecting the SEND MESSAGE or + PUSH MESSAGE option, a Send Message To Terminal pop-up 
window will display. The window includes the Message Title and Message body text fields. 

• Message Title: ANS min = 0, max = 64 characters

• Message: ANS min = 0, max = 256 characters

Enter the text into the desired text fields and select [OK] to save. If using Group Management, set up the 
Push time/date in the Push Configuration section and select [ACTIVATE] to save Push settings.
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When the message is successfully pushed to the terminal, the message will display in the terminal.
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19.26 Reseller Tree
The Reseller tree displays all of the Resellers, Sub-Resellers and Merchants within the related profile.

• Display message “View More...” in the Reseller tree structure to display 
additional resellers after every 100 Resellers. Select [View More...] to see more 
Resellers.

• A flat list tree type display format for displaying resellers.

To access 100+ Resellers, select [Terminal Management] > [View More...].
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To access view tree format, select [Terminal Management] > Terminal Management.
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19.27 MD5 Certification Detail
The MD5 Certification number will display in the PUK Certification Detail section. If the key is 26+ 
characters long, it will wrap to the next line.

To access, select [Terminal Management] > [Reseller] [Terminal List] > [Terminal] > [Setting] > PUK 
Certification Detail > MD5.

20. Report Center
The Report Center supports copying and exporting reports.

20.1 Simplifying The Report Center
The view-only reports have been removed to simply the Report Center, and now all reports are available 
for export and download.

20.2 Report Interface and Layout
The Report Center has been designed to be intuitive and provide flexibility.
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20.3 Model Report Example 
Step 1: To create a Model Report select [Report Center] > [All] > [Model Report] > [+ REPORT TASK].
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Step 2: In this example, select from the optional Reseller line on the right side the Options [icon]. A pop-
up window will display as Reseller. Select the desired [Reseller] > [OK] to confirm.
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Step 3: In this example, select the right-side options from the optional Merchant line [icon]. A pop-up 
window will display as Merchant. Select the desired [Merchant] > [OK] to confirm.

Step 4: In the Model section by default all models are selected. If certain models are desired then select 
the [+ PLEASE SELECT].
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Step 5: In this example select the desired terminal model(s) [A60] > [OK] to save.

Step 6: To create the report select [CREATE]. Note the report criteria is displayed.
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Step 7: The new report will be displayed at the top of the report list and while the report is processing the 
report the Action status will display as In queue. 

Step 8: When the report is finished processing the Action status will display as Completed. To download 
the report, hover the cursor over Completed and select the [download arrow icon].

Step 9: Locate the downloaded report and open the file to review report data.
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20.4 Create App Parameter Report Example
The App Parameter Report supports multiple version of an application and the report layout has been 
simplified.

Step 1: To create an Application Parameter Report select [Report Center] > [All] > [App Parameter 
Report] > [+ REPORT TASK].
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Step 2: In the Condition window on the App line select the [View All icon]. In the App pop-up window 
select the desired [application] > [OK].
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Step 3: On the Application Versions line to the right select the [View All icon]. In the Application Versions 
pop-up window select the desired application [version] > [OK].

Step 4: On the Parameter Template line to the right select the [drop down icon]. In the pop-up window 
select the desired [parameter template].
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Step 5: On the Reseller line to the right select the [View All icon]. In the Reseller pop-up window select 
the desired [Resellers] > [OK].
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Step 6: On the Merchant line to the right select the [View All icon]. In the Merchant pop-up window 
select the desired [Merchants] > [OK].
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Step 7: In the Model line to the right select the [View All icon]. By default all models are selected. Select 
the desired example model [A60] > [OK].
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Step 8: In the Export Content line to the right select the [View All icon]. Select the desired [parameter 
files] > [OK]. 

Note: Parameters are listed based on the selected application versions.
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Step 9: In the Condition window review the fields and then select [CREATE].

Step 10: The saved report will display in the list. While the report is processing the Action status will show 
as In queue. When the report is ready the status will show as Complete. To download the report hover 
the cursor over the Completed status and select the [Download icon].
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20.5 Copy App Parameter Report Example
This new copy function is for generating reports. It is now possible to copy the report search criteria from 
an existing report to a new report with some slight modifications. This function is especially useful for the 
Terminal App Parameter Report which contains many required parameters.

Step 1: To create a Copy App Parameter Report select [Report Center] > [App Parameter Report] > select 
desired report from the list of reports and hover the cursor over the Completed status and select the 
[View icon].

Step 2: Review the Condition page and select [COPY] to copy the report.
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Step 3: A pop-up window called Copy Report will display. Select [OK] to copy.

Step 4: At the Condition window review the fields and then select [CREATE] to create a copy of the report.
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Step 5: The new copied file will be listed with the other saved files. While the report is being created the 
Action status will show as In queue. When the report is ready the status will change to Completed.

Step 6: An email will be sent to the profile email address. Select the green [APP PARAMETER button] to 
be taken to the App Parameter Report center.
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20.6 App Installation Report Example
The App Installation Report is included in the Report Center. This report can be used to get statistics on 
the terminals in which a particular application is installed. 

Note: The Installed Terminal page in the App Detail version list page was removed as a duplicated 
functionality.

Step 1: Select [Report Center] > [All] > [App Installation Report] > [+ REPORT TASK].
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Step 2: In the new Condition window in the App line select the drop down option on the right to select 
the application installed on the terminal. In the pop-up App window select the desired [application] > 
[OK].
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Step 3: In the Application Versions line to right select the view all [icon]. Then, from the new pop-up 
Application Version window select the desired [application version] > [OK].
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Step 4: In the Reseller line to the right select the [View All icon]. In the Reseller pop-up window select the 
desired [Resellers] > [OK].
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Step 5: In the Model line to the right select the [View All icon]. By default all models are selected. Select 
the desired example model [A60] > [OK].
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Step 6: Review the information and select [CREATE].

Step 7: The saved report will display in the list. While the report is processing the Action status will show 
as In queue. When the report is ready the status will show as Complete. To download the report hover 
the cursor over the Completed status and select the [Download icon].
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20.7 Push Templates

20.7.1 PUSH TEMPLATE USER INTERFACE

Push Template User interface.

• The layout displays all of the applications and application versions attached to 
the template. 

20.7.2 PERMISSION OPTIMIZATION

Optimized the permission of “Push Template.” If Users don't have full privileges for “Push Template,” they 
are not allowed to delete or create Push Templates in terminal management or group push, and the Users 
can only use the existing push templates.
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v4.0 | 243

PAXSTORE N.A. Reseller User Guideer Guide

20.8 User Management
Added remove the SSO User feature for marketplace administrator. The behavior is the same as normal 
marketplace.
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20.8.1 USER ACCOUNT STATUS CHANGE NOTICE

A Marketplace Owners and Reseller feature, to notify when the user account status was updated. When a 
user's account is activated, disabled, or suspended, a notification email will be sent to the user.
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20.9 Developer Approval

20.9.1 DELETE SANDBOX TERMINAL

Added a new feature to delete a sandbox terminal. Previously if a terminal SN has been registered as a 
developer's sandbox terminal, this terminal cannot be registered in the marketplace anymore. The 
PAXSTORE User needed to contact the developer to delete the sandbox terminal first. 

Now the marketplace administrator can delete the sandbox terminal directly rather than having to 
contact the developer.
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20.10 Terminal API
Added a new API to return all terminal details and accessory information.

• TerminalApi ->public Result<TerminalDTO> getTerminal(Long terminalId, 
booleanincludeDetailInfo).
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20.11 Others 
• Added Russian language support.

• As the Paydroid OS uses a new resource package format, the resource package 
format supported by PAXSTORE has been changed to the latest version. The old 
resource package is no longer compatible.

• Optimized terminal replacement logic and enhanced replacement security. The 
PAXSTORE client needs to be upgraded to V7.2 or higher. 

• Removed the feature to automatically check User information when adding 
Users. This is to prevent malicious User enumeration. Now when entering the 
User's email, no User information will pop up.

• Optimized the double confirmation of sensitive operations. Previously, the User 
had to re-enter the password to double confirm sensitive processes, which 
increased the possibility of password leakage. Now, we provide two ways to 
double ensure the sensitive operations: two-factor authentication or just by 
verification code. 
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• Removed the 'download' function of the parameter template from the push 
page.

• Removed 'Estate Management' at the marketplace level.

• Fixed JIRA Ticket PAXSTORE-422.

• Support for the Italian language.
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Customer Support
For questions or help with the PAXSTORE, please contact your service provider or PAX customer support.

Monday-Friday 9:00 AM to 1:00 AM EDT
Saturday 9:00 AM to 5:00 PM EDT
Sunday Closed
Hours Subject to Change

Contact Information
support@pax.us
(877) 859-0099
www.pax.us

PAX Technology Inc.
8775 Baypine Road
Jacksonville, FL 32256

This document is provided for informational purposes only. All features and specifications are subject to 
change without notice. The PAX name and PAX logo are registered trademarks of PAX Corporation and/or 
its affiliates. Other names may be trademarks of their respective owners. Copyright 2021, PAX Technology 
Limited, All rights reserved.

*PAX Technology, Inc. is not responsible for the content, quality, accuracy or completeness of any 
information or materials contained in on these pages. PAX Technology, Inc. does not endorse any 
content, viewpoints, products, or services contained on these pages and shall not be held liable for any 
losses caused by reliance on the accuracy, reliability or timeliness of such information. Any person or 
entity that relies on any information obtained from these pages does so at his/her own risk.
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